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l‘ The working of a computer involves the processing of data received from

input devices and providing the output using output devices.
99

CPU is the “brain” of the computer.
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The main difference between a supercomputer and a mainframe is that a supercomputer channels all its power into
executing a few programs as fast as possible, whereas a mainframe uses its power to execute many programs

concurrently.
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4] - Micro Computers.

Desktop Computer: A personal computer, sufficient to fit on a desk and is designed for
regular use at a single location due to its size and power requirements.

Laptop Computer: A portable computer with an integrated screen and keyboard. It is
generally smaller in size than a desktop computer and larger than a notebook computer.

Palmtop Computer/Digital Diary/Notebook/PDAs: A hand sized computer that have
no keyboard but the screen serves both 2< an input and output device.
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It consists of the Arithmetic Logic Unit (ALU) and Control Unit [CU).

- ALU executes all the arithmetic and logical operations such as basic additions,
subtractions and comparisons (+, -, *, /, <, >, =).

- CU is like an execution unit which controls the rest of the computer instructions
and coordinates with other devices in the queues.

Docs everything except AW
3) Memor  Detices

Memory devices are used to store data and programs on a temporary or permanent
,‘d uﬁ@g basis. Memory is categorized as primary and secondary storage. The primary memory is
@R ° thestorage space in computer where data and instructions to be processed by CPU are
[ ll“ B \*’_‘/ \¢ stored. Primary memory is also known as main memory and consists of RAM and ROM.
= Secondary storage is used to store data and information permanently. These include the

storage devices like HDD, DVD, Flash Drives, Memory Cards etc.
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(.' Apple Macintosh (macOS) ]

g  Apple Macintosh, commonly known as macOS, is actually the first OS to provide the GUI. It is designed

to run with Apple computers. It is not as widely used as the Windows OS; thus fewer applications have

. been developed to run on macOS. It is a powerful, easy-to-use operating system and it is popular with
professional graphic designers, desktop publishers, and many domestic users.

G Microsoft Windows )

Microsoft’s Windows is by far the most popular operating system for PCs. Most of the desktop applications
"
O

are developed to run under windows as compared to any other OS. Windows comes in different versions
and was initially designed to run with Intel or Intel-compatible processors. Windows 10 is the latest
release from Microsoft, which has a modern user interface and supports tablet computing as well.

C. Linux ]

& Another famous name in the operating systems category is Linux. The specialty of Linux is that it is an

Open Source OS, which means it is freely distributable. It can be customized and used with different types
o2 of computers, tablets or smartphones. We will learn about it in details at the end of this session.

@ Android J

Android is one of the Linux based operating systems developed by Google and the Open Handset
Alliance (OHA), a coalition of more than 30 hardware, software and telecom companies. It is designed
primarily for mobile and touchscreen devices such as Smartphones and Tablets. Android’s User Interface
is mainly based on touch gestures that correspond to real-world actions, such as swiping, tapping and
pinching along with a virtual keyboard for text input.

Android is now the most popular mobile OS providing lots of exciting features. Its open nature has
encouraged a large community of developers to develop Android based applications (or apps). Thus,
Google Play Store has over billions of android apps.

Overview of Diffrent Operaling Sysheme
C.Windowsm )

Windows 10 is the latest version of Microsoft Windows operating system. Itisa [E i
major shift from the previous versions of Windows. It has been essentially [EEEEE=SEM
modernized to support the touch devices and pen input. Lots of enhancements |l
and new features have been added to it. The following parts will take you

through the Windows 10 Operating System.

(6' New Features of Windows 10 )

Once you Sign in to Windows 10, you are in the all-new Windows 10 environment. You should first go through the
new features Microsoft has come up with. Some of the interesting and exciting new features of Windows 10 are as
follows:




New Start Menu

Microsoft has changed the start menu based on the experiences and feedback from the users. It is now more
comprehensive, efficient and modern. It has a tile-based start screen along with the classic features of a start
menu. The tiles on the start menu can display live contents making it an intuitive start. You can customize it right
on its place, such as resizing tiles or start menu itself and pin or unpin applications etc.

|/
Keyboard shortcut to open start menu is “Ctrl+Esc” or simply press“Windows key” on keyboard. Ay

Windows Ink

As the world is moving towards the mobile and touch based computing, Windows
10 has introduced the Windows Ink feature. It allows you to use pen input in
different apps or annotate on snapshot of your current screen. If you have a touch
screen device, the Windows Ink icon appears in the Notification Area of the Taskbar
by default. Otherwise, to activate it, you need to Right-Click on the Taskbar and
choose “Show Windows Ink workspace button.” When you click on Windows Ink
icon, a sidebar of the Windows Ink workspace appears, which usually has the
following options:

WINDOWS INK WORKSPACE

Sticky Notes

Sticky Notes: Allows you to create brief sticky notes by using pen tools such as
adding a schedule reminder. Windows uses character recognition (or handwriting Bt
recognition) to read your sticky notes.

Sketchpad: Enables you to create freehand drawings with pen tools and save it as
an image file. Recently used

Screen Sketch: Allows you to draw or annotate on a snapshot of the current m e e a Y
screen.

Get More Pen Apps: You can click on “Get more pen apps” link to open the
windows store and download desired pen apps.

Virtual Desktops

Virtual Desktop is the very useful feature Microsoft has provided with
Windows 10. This gives you the experience of working with multiple
screens; although having just one. So while you work on multiple apps,
you can better organize them with multiple Virtual Desktops. You can S il &
group your personal apps together in one desktop and work apps in
another. You can Add New Desktops as you want and switch between
them easily. The Task View button on the taskbar helps you manage it.
You can easily move running apps from one desktop to another with just
the Right Click of the mouse. Interestingly, if you close a Virtual Desktop,
the apps that were running on it won't be closed, rather they will be
shifted to previously available desktop.

Cortana or Search

Cortana is another enhancement in Windows 10. Cortana is a voice-activat-
ed personal digital assistant, which provides relevant suggestions and alerts. Hi I'm Cortana
The more you use Cortana, the more personalized your experience will be.
For example, you can use Cortana to find files/apps on computers, search the
internet, send emails, help out with navigation, setting reminders, and more.
Cortana is available only in certain countries or regions. It is accessible from
the search box at the taskbar right next to the start button. You can
command Cortana by either typing in the search box or by clicking on the
mic button to talk to her.

You can also say “Hey, Cortana” to activate via Mic through audio input.
When Cortana is not available, it is replaced with the Windows Search, helping you to search for apps, files, folders,
and settings on your computer.



P

@ Apple Macintosh (macOS) J

MacOS is the graphical operating system powered by Apple MAC.
Compared to other OS, it is simple to work using high-end graphics. It is
specially designed to run on Mac(Apple) devices. MacOS provides a
complete suite of smart apps on its app store. It also offers cloud storage
"iCloud" to store your personal information and to synchronize with all
other devices. It works with your iPhone also. It is designed to provide data
security and protection with enabled security measures.

The latest version of Apple’s operating system is called macOS High Sierra. Upgraded with different software
enhancements, it also lays the foundation for future innovations in the world of VR (Virtual Reality) and AR
(Augmented Reality).

Features of MacOS High Sierra

What can | help you with?

* Apple File System.
e Virtual reality for Mac.
e Siri

¢ iCloud Drive and Optimized Storage

IYA’YGcleI-fOY) o£ Open Source. Sellwor

- Open source software is a free to use software for your individual use. A developer of such software

/\ freely share knowledge and makes the source code available to the public. Generally, such

» software is distributed with a license which allows other developers to modify it and/or add to it.
Some examples of open source software are Linux, Android, Ubuntu, Firefox etc.

_— Generally, the major difference between open source software and commercially available

W programs is the huge amount of money which you pay as a license fee. Some developers make free

products for all users while other developers create commercially available products. Some
developers come with a different idea and create a free and paid version of their products.

(! Introduction to Linux ]

In 1983, Richard Stallman started the project on developing a free operating system called the GNU
(Linux) project. The concept was developed with the new idea of open source code to the users without any
copyrights. The operating system and most of its software is created by volunteers and employees of
companies, governments, and organizations from all over the world. It emphases on the right to use the
software code and motivates the users to develop with new enhanced features. Generally, it is distributed
under General Public Licenses. (GPL) which to give the freedom to the users to change and prevent
software being changed into proprietary software.

The developer has the freedom to contribute to the operating system and it is free to use. This co-operative
development model is meant for the benefits of everyone. That is why it is better known as Socially Responsible
Software. Tech world abbreviated it as FOSS - Free and Open Source Software.

Linux has many other benefits, including speed, security, and stability. It comes from the well-established UNIX
family of OS and so has been built to keep security in mind. Hence, viruses, worms, spyware, and adware are
basically a non-issue on Linux.



Applicakion Softuwore

The Application software is a group of programs that facilitate the end-user with different features of the
computer to perform certain tasks. Application softwares are designed specifically in the view of the end-user’s
requirements. You will learn practical skills of this type of software in the coming sessions.

. . ] Office
WMS Office, Microsoft Edge, Safari, etc.

EEPL0
Applications Software can be categorized into two types.

C. General Purpose Application Software ]

Applications that are used commonly by computer users are called general purpose applications,such as word
processors, spreadsheets, databases, desktop publishing packages, graphics packages etc

(. Specific Purpose Application Software ]

Applications which are designed for specific task or organization according to the defined requirements of the
user is called as Specific Purpose Application Software. Examples include Air Traffic Control System, Learning
Management System for Universities etc.

By now, you have got a basic understanding of an OS and basic information about the different OS available in the market.

Software Set of programs

Open Source Software It is a freeware software can be used without licenses

oS Operating System

GUI Graphical User Interface

Command Line Interface

Computer Applications

Classification Introductions to Open
of Software Source Software

System Software Introduction to Linux

Application Software

Introduction
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A text processor provides variant common useful features, such as:

A Font and Formatting Options.

Referencing and Citations.

Design and Layout.

Spelling checker.

Smart tools such as ‘Tell me box; Lookup, etc.

fopulor Texk Procesorg
@Apple Pages ]

‘Pages’is a text processor and a part of a productivity suite called iWork along with both
Keynote and Numbers, and is recognized for its user-friendly, intuitive interface. It is a
product of Apple which supports and runs in the Apple products such as Mac Book and
iPhone, with macOS and iOS operating systems. Pages have distinct features to create and

‘ collaborate the documents. Its powerful word processor helps you create documents by
touch devices to illustrate with hands and allows you to collaborate your documents with
any devices and anywhere to work with your group in the real-time. It is compatible with
mobile devices such as iPhone.

C. Microsoft Word 2016 )

Microsoft Word is the text processor, which is one of the programs of MS Office 2016 suite.
It is developed by Microsoft Corporation. MS word supports the different operating
systems such as Windows and macOS. It can be installed and run in the microcomputers
such as smartphones, tablets. MS Word let's you create attractive documents with a
different type of templates such as Letters, Flyers, Brochures, Manuals, CVs and more. It
also allows you to collaborate your work with anyone. Word 2016 has various features such
as inserting online pictures which can be helpful to create the documents.




Overview of MS Word 2016

(. User Interface of Word 2016 J
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It provides the easy access to the commands which you use frequently. By default, it has the Save,
Quick Access Toolbar Undo & Repeat commands. You can add or remove commands to Quick Access Toolbar by simply
clicking on the Customize arrow button on its right.

Almost all the commands in Word 2016 are compiled together in the form of a Ribbon, in order to
help you work efficiently.

At the top of the Ribbon is a set of tabs. Clicking a tab displays an associated set of commands.

Related commands of a Ribbon Tab are organized in Groups.

Clicking the Dialog box launcher displays the associated dialog box or pane.

It allows you to Show or hide the Ribbon. Click on it to choose from the menu options Auto-hide
ribbon, Show Tabs, or Show Tabs and Commands.

The white area in the middle of the Word 2016 user interface is the Work Area or Workspace. This
represents the actual page where you type text, edit or format a document.

The Insertion Point or Cursor is the blinking vertical line in the Work Area. It indicates the current active
place in the document where you can insert text, images, apply editing or formatting commands.

It helps you to view and adjust the position of the contents of the document.

It displays the information about the current document such as the total number of pages, the current
page number, total number of words in the document, current proofing language and proofing status.

Three view buttons Read Mode, Print Layout, and Web layout on the right side of the Status bar
allows you to easily switch between the document views.

These allow you to easily adjust the zoom level of the document contents as per your convenience.
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C. New Features of Word 2016 J

Tell Me Box

In Word 2016 user interface screen, you might have noticed
a text box on the right of the ribbon tabs with a bulb sign
that says “Tell me what you want to do..." It allows you to do
the things quickly and efficiently, keeping you free from *add a comment"
remembering and locating the commands in various tabs &
ribbons. All you have to do is to simply enter a word or a
phrase in the Tell Me box about the command you want. It jj “change my font color”
provides you a list of the related options to get help with a
particular command.

Try

“insert a table"

“"draw with a pen"”

Smart Lookup

Another interesting feature of Word 2016 is ‘Smart Lookup! It allows you to get the definitions, Wikipedia articles,
and other top related searches from the web about any word or phrase in your document. Thus, bringing the
research directly into Word 2016.

The Fle Tab

The first tab in Word 2016 is the File Tab. When you click the File tab, the document window becomes invisible and
a menu is displayed on the left with the options such as Save, Close, and Print a document. It also displays the
information about the current document on the right side. The view of File tab is also called the Backstage View.
Following are the options to manage the documents under File Tab.

Keyboard Shortcuts

e Create a new document.
X CTRL |+ N| CreateaNew Blank Document
¢ Saving a document. ) )

¢ Using save as option. CTRL |+ S| SaveaDocument
e Closing a document.

¢ Opening an existing document.
e Pinning a recent document.

e Printing a document.

CTRL |+ 0} Open a Document
_CTRL |+ W/ CloseaDocument
CF12 ] Save As a Document

CTRL |+ P | PrintaDocument

- By default, a document in Word 2016 is saved with the file extension .docx.
-The Save As option is the way to save the document to a different file format.

—~ @ oneDrive @ OneDrive
(.' One Drive ] ) e i
When you save a document in OneDrive, your document is stored in a central ~ [# 2o r- _____

location that you can access from anywhere. Even if you're away from your PC, rowse : :
you can work on your document whenever you have a connection to the Web. l:l D |:|




Overview of Brrnw@hng Opkcms

@ Home Tab )

The next tab after the File tab in Word 2016 is the Home Tab. Home tab is generally used to format the documents.
You can use effects like Bold, Italic, Underline, Size of Text, Alignment of Text, Quick Styles and Formatting of the
whole paragraph, etc. You can also use it to find and replace words or phrases in the document.

2] D= (Y (4] Do
fie [ et Desion  Loyout  References  Mai Review Q Tellmew

Calibri Body) *|11 ~| A A Aa~ fo [

ent1 - Word = -

you want to do. Sign in

o P Find ~

M 94 2L TR aaebcee| asBbeede AaBbCc AaBbCcl AQB aasbeer aasbeede AaBbeede Aasbcche MaBbCeDe e
- 5 repiace
[3 Select ~

o cating

Pasiz. 2 Copy L. A .| &~ TNormal | TNoSpac.. Heading! Heading? ~ Tle  Subtie  SubtleEm.. Emphasis Intensef.  Stong |
=" FomatPuinter I8 7 U -k x| B A <] P 9 9 P 9 |5

Clipboard 3| Font 5 Paragraph g Styles

The Home Tab commands are divided into five groups.
Clipboard This group contains the main editing commands such as Cut, Copy and Paste.
Font This group commands enable you to modify and enhance the appearance of your text.
Paragraph This group commands enable you to format complete paragraphs.
Styles This group commands enable you to apply pre-defined formatting styles.

This group commands help you to find and replace text as well as select text or objects.

OVerview of Hlushokons ond Dezign  of Docurments
@InsertTab J

The Insert Tab has a lot of useful features that enable you to insert different items in your document. You can insert
acover page, table, pictures, shapes, chart, hyperlink, header footer, equation, symbols, etc. in your document. The
commands in the Insert Tab are divided into several groups.
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@ Design Tab J

The next tab after the Insert tab is the Design tab. This tab consists of commands that enable you to quickly apply
different formatting styles to your document. It also helps you to add page background where you can apply a
watermark, give a color to the page and insert page borders as well.
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c. The Layout Tab ]

The Layout tab allows you to customize the way your document’s page is set up. It helps you to change the
document orientation, page size, margins, indentation, line spacing, and paragraph settings. It is better to adjust
the Page settings before you start creating a document.
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The following options are available in the Page Setup group of Layout Tab.

Used for referencing

Text Processing Productive tool to create text document

Text Processing

4 2\

7

Starting
Word 2016

Overview of
formatting Options

Overview of USfer Interface kud The Home Tab The Insert Tab
i of Word 2016 :
Text Processing The Design Tab

=
New Featuers
-
Popular text The Page Layout Tab
—
—

Overview of lllustrations The Reference Tab

Introduction )
and Design of Documents

Processors

The File Tab




Overview of Refrencing
@ Reference Tab ]

The References Tab commands help researchers & professionals in creating references in the document. In this
section, you will learn about footnotes and endnotes.
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Footnotes and Endnotes

Footnotes and endnotes are used to explain, comment on, or provide references to text in a document. Footnotes
are referenced items that are used to cite a source or provide additional information about a quote or some such
item within a document. Footnotes appear at the foot (or bottom) of the page:

Endnotes are very similar to footnotes and serve the same general purpose. The difference is that endnotes do not
appear at the bottom of each page, but at the end of a section, a chapter of a book or at the end of the book itself.
A number or symbol on the footnote or endnote matches up with a reference mark in the document.

Insert footnotes and endnotes
Word allows you to create both footnotes and endnotes. You have complete control over placement and appearance
of both of these note types in your document.
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Internet of Things (loT)

2 - On the References Ribbon, in the Footnotes
The Internet of Things is transforming every comer of life: the home, the office, city streets and beyond. Io|
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ToT involves extending internet connectivity beyond standard devices, such as desktops, laptops, smartphones anj
tablets, to any range of traditionally dumb or non-intemet-enabled physical devices and everyday object|

with , these devices can and interact over the internet, and they can be remote]j
monitored and controlled.
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(. Apple iWork — Numbers )

The “Numbers”is a kind of spreadsheet applications product of Apple. One of the programs
of iWork software package is Pages. Numbers have similar features to Microsoft Excel. It is
available for Apple products which work through iOS such as iPhones and iPads. Numbers
also supports touch pen input.

It has various features listed below.

Supports Touch devices with Apple Pencil. It can be shared with any device.
It can collaborate with any user. Friendly with Microsoft Excel.

C. Microsoft Excel ]

MS Excel is the product of Microsoft. It is the productive tool from Microsoft Office suite
family, with a member like MS Word. Microsoft Excel is the spreadsheet program that
comprises of worksheets used to analyze data and provides an easy way for all types of
computations. It can be used with all types of microcomputer devices like Laptops,
Desktop, Smartphones etc. It can be used on various platforms like Android, iOS etc. It
supports Windows and Mac OS.

Overview of MS Lxeed 4016
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(’ Features of Excel 2016 J

P Quick Access tool P Automatic Preview Options

P Functions P Tell me Box

p Forecasting P Sunburst charts

p Date Grouping » 3D Data Map

» Histograms and Pareto charts P> Effective automatic calculations

C. Starting Excel 2016 )

To start the excel 2016 in Windows 10, follow the steps given below:

1 - Click on the start button to open the start menu.

2 - Locate and click on the Excel 2016 from All Apps list.

The Start Screen of Excel 2016 appears with a list of recently used files
and available templates. You can either open an existing file, choose a
template, or start with a new blank workbook. You can also press the
ESC key to start with a new blank workbook.
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(‘ The User interface of Excel 201 6]

Excel 2016 is a very interactive program which is very easy for the novice user. It is organized in many tabs
consisting of groups and functions. Same is mentioned below in the screenshot.
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. Ribbon includes a set of commands located below different tabs. Every tab
A Ribbon < o . .
is split into groups, having logically related commands.
This field, positioned to the right of the ribbon tabs, lets fast access to Excel
B Tell Me Box .
commands and functions you need to use.

You can show or hide a ribbon to maximize or minimize your workspace. You
[l T WRIE I EWAOTIIGIEY  could select from the options: Auto-hide the ribbon, show Tabs simplest or
show Tabs and instructions.
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A Worksheet is a workspace, which is organized into rows and columns.
Used to keep and manage information in the form of a table.

The intersection of a row and a column in a worksheet is called a cell. An
active cell is the one which is selected in the sheet with a green outline.

Columns are the vertical separations in the sheet. The Column has sequential
letters at the top as A, B, C etc.

Rows are the horizontal separations in the sheet. This rows named in the left
side of the worksheets as 1, 2, 3, etc.

Name box is just beside the formula bar which recognizes the selected cells and
any other objects on the worksheets. Every cell has its own address recognizes
by the column and the row number (Example A1, B16, Z28 - where alphabet
represents the Column and number represents the Rows).

H Name Box

| FormulaBar Formula bar is mainly used to enter a formula to calculate cell data.

) SheetTab At the bottom of the worksheet where the name of the sheets is displayed.
Sheet tabs help manage different worksheets.

K  statusBar At the bottom of the worksheet, status bar show count, sum, and an average of

selected cells of data. It contains view buttons, zoom slider, and a zoom button.




Crea,émgz A Workbook

- A’ workbeoK s &mply/ on excel Bile that Colains ane. or wmore workcheeds. .

Excel workbook is saved with the extension “xIsx". J

Excel template is saved with the extension “xItx".

@ Entering the data ]

The text, numbers, dates, and formulas can be entered in the worksheet cells. Select the cell and type the data
you want to enter. Use “Enter key and Tab Key” to navigate between the cells.

.

(. Tips to Navigation a Worksheet )

< J A J > J v used to move one cell left, right, up or down directions.
N N N N - A J
TAB Key used to move the active cell one column to the right in the worksheet.
[ CTRL '+ Home used to move the active cell to cell A1 in the worksheet.
N —d Na— _— S S
CTRL |4+ End to move the active cell to the last cell in the worksheet that contains data
N el N— )
CTRL |+ v used to move the active cell to the last row in excel sheet that contains data.
N — N —
CTRL |+ » used to move the active cell to the last column in excel sheet that contains data.
CTRL is used to select non-sequential cells.
Shitt is used to select cells sequentially.

C. Selecting the cells )

In a worksheet, you may frequently need to select multiple cells to edit data, apply some formatting options,
perform mathematical operations, etc.
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8 435100106 |Saleh 29 6 8 49
9 435100107 |Hussam 23 9 10 44
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To select sequential and non-sequential cells; Name Box or Mouse can be used.

Click on a cell and drag the mouse over a group of cells you want to select.

@) Excel highlights the selected cells in grey color.

() Use the Select All Button if you want to select all the cells in the worksheet.

Enter the cell addresses of the first and last cells separated by a‘colon (:) in the Name Box and press
Enter key e.g. A2:F6.

efa - —
D &b Calibri 112 A A== =3
By ~
Paste . BIU- H- D-A-E=E=€%E 8-
Clipboard & Font r‘. Alignment r
A2:F6 0 : F 435100101
4 A B C D E F G |
1 ID No. Name |MidTerm| TAC |SL Project|Final Term
2 1435100101 |Khalid 28 8 9 48
3 |435100102 [Abdullah 25 9 9 45
4 |435100103 |Bandar 29 10 10 49
5 1435100104 |Yousuf 30 10 10 50
6 |435100105 |Fahad 23 8 10 38
7 1435100106 |Saleh 29 6 8 49

To select non- sequential cells using name box, Enter the cell addresses separated by commas in the Name
Box and press Enter key e.g. C3, D5, E8, F4.
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Mana%ing Worksheels

@Change Tab Color ]

A tab color applied to worksheet tabs, help you to
identify different worksheets in a workbook.

To apply a tab color, follow the steps given below:

Right click on the sheet tab and point to Tab Color
option from a popup menu.

e Choose a color from the displayed color palette

@ Inserting a Worksheet ]

In Excel 2016, a workbook contains only one worksheet by default. You can insert more worksheets to your

workbook as shown in below screenshot.

To insert an additional worksheet, follow the
steps given below:

o Right click on the sheet tab.

9 Click Insert option from the popup menu.
9 Click on the Worksheet option.

e Click on OK button to insert worksheet

( Press Shift+F11 to insert a new Worksheet. )

T Ancther method 2

@ Deleting a Worksheet ]
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You can delete a worksheet that you no longer need in your workbook. A worksheet can only be deleted if the

workbook contains more than one worksheet.

To delete a worksheet, follow the steps given below:

0 Right click on the sheet tab you want to delete.
9 Click Delete option from the popup menu.

Excel prompts you with a box to confirm the
deletion if the excel sheet contains data.

o Click on Delete button to delete the worksheet.

Insert...
[X Delete
Rename
Move or Copy...
Q] View Code
E Protect Sheet...
Tab Color 4
Hide

Selec eets

Sheet! "] “Sheet2 |

laths | Science | Total
56 85 201
87 90 227
56 48 159
89 56 225 9
3 Microsoft Excel
! Microsoft Excel will permanently delete this sheet. Do you want to continue
(4 3 =1
® K1 I




@ Renaming a Worksheet ]

Excel 2016 assigns a default name to each worksheet in a workbook like Sheet1, Sheet2. You can give specific

names to worksheets to help you identify their content
To rename a worksheet, follow the steps given below:

o Right click on the sheet tab you want to rename.

Click Rename option from the popup menu and type a
new name for the worksheet.

( Double click on the worksheet tab to rename it. )
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(. Move or Copy a Worksheet ]“ﬁp

- A Le | e | B
1 [Marks |
2 Id No S aths
3 | 100112323] | ER Delete 56
4 | 100112324/ | Rename 87
5 | 100112325 Move or Copy... 56
6 |100112326] | o o 89
7 | 100112327 56
P m Protect Sheet...
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Moving a worksheet within the same workbook or to a different workbook is helpful to keep worksheets in order.
Copying a worksheet helps you to use the same worksheet in the same or different workbook.

To Move or copy a worksheet, follow the steps given below:

o Right click on the sheet tab you want to Move or Copy.

Select Move or Copy option from popup menu. It opens

Move or Copy dialog box.
» You can move selected sheet to another workbook.
» You can move selected sheet in the same workbook.

9 Select Create copy checkbox to copy the worksheet.

6 Click on OK button.
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You can also Insert, Delete, Rename, Move or copy sheet and change Tab color from cells group of the Home Tab.

).

( Drag option also can be used to Move

@ Other Sheet Options )

Select All Sheets

Makes a worksheet invisible from sheet tabs.

Selects all worksheets so that a formatting option can be applied at once, like Tab color.



The Home Tab

The Home Tab provides a collection of commonly used commands for easy access.
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(. Following are different groups in the home tab )

@[[s].LEICR This group contains main editing commands such as cut, copy and paste.
Font This group contains commands used to apply a range of formatting options.

This group contains commands used to position cell data and merge cells.

This group contains commands used to apply different number formats to data.

Styles This group contains commands used to apply various styles.

.

CeIIs This group contains commands used to add, delete and format cells, rows, columns, and worksheets.

This group contains commands used to sort, filter and calculate data.

The. Insart Tob

The Insert Tab emphasis to learn about Charts, Pictures, 3D Maps, Links, etc. Here specifically you will learn to insert
charts and format Charts in Excel 2016 which helps you to visualize your worksheet data in a very attractive way.
About the visualization topics, you will learn in detail in the coming chapters.

P

Q Chart and Elements of a Chart J
A Chart is a graphical illustration of information, - Miicond D
Charts are especially helpful to illustrate the ‘ D D 5 =
workbook data graphically and in an attractive 70 o o
manner, which makes it easy to visualize -
comparisons. s a8 o a9
Chart Buttons: To format the chart easily you
have chart buttons which enables you to e = 27 = = 7
change different options such as chart 18
elements. :
Ibrahim Yazeed Mohannad Tal Abdulelah Badar
Gsludemuames Mid Term  m Final = Total Marks
Chart Area It contains all the chart elements which cover the entire area of the chart.
Plot Area The area that contains the representational data is called plot area.

Chart Title Shows the title of the chart.




From the plotted area actual points represented with data points.
It's a section to show the vertical title as Y-Axis Title
It shows as X-Axis Title as a horizontal title.

It shows data represents in a different color.

It shows the labels of the data on the chart.
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@ Inserting Chart ]

Excel 2016 provides a number of chart types which are available to create. It also recommends charts as
suggestions to create to the provided data. Based on the data in the rows and columns you can create the
chart by selecting the best chart type.

To insert a column chart, follow the steps given below @ | = WEEIIEYY- = |
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Move Chart Enables to move the chart in a separate chart sheet or a worksheet
C Styles It provides you the customized styles with different colors to apply on the charts.

Enables to change your existing chart to a different chart type. For example, you can
(S ED R LT change a Column Chart to a Bar Chart.
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The Page Layout tab lets you modify the way your worksheets are set up into different pages. It helps you to
modify the Theme, Page Size, Margins, Print Area, and more. Here you will learn about the printing options.

Page Layout Formulas
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The Formulas Tab enables you to calculate data using a variety of functions available in Excel 2016 to make easy
calculations. Excel 2016 provides several built-in functions to perform mathematical, statistical and logical
operations. Function Library group in the formulas tab contains a number of functions grouped in different
categories such as Financial, Logical, Text, Date & Time and Math & Trig.
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File Home Insert Page Layout Formulas
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Insert  AutoSum Recently Financial Logical Text Date& Lookup & Math&  More
Function - Used - - ~ v  Time~ Reference~ Trig~ Functions~

Function Library

Logical Logical Functions are used to test for a condition to evaluate it as true or false. It
ogica includes functions such as AND, FALSE, IF, NOT, OR, TRUE, etc.

T Text functions are used to manipulate text strings. It includes functions such as
ext CHAR, LEN, LOWER, PROPER, TEXT, UPPER, etc.

These functions perform arithmetic operations, conditional sum, exponents &
Math and Trig logarithms, and the trigonometric calculations.
It includes the functions such as SUM, SUMIF, LOG, COS, SIN, etc.

It includes Statistical and Engineering functions such as AVERAGE, COUNT, MAX,

More Functions MIN, CONVERT, DELTA, etc.

Q Functions J

A Function in Excel 2016 is a pre-set or inbuilt formula that performs calculations automatically.
Each function has a specific syntax, i.e. a set of rules associated with it.

(i' Creating a Formula J

A formula is an expression that executes all the calculations in the cell’s data. A formula with arithmetic operators
like +, -, *, /, %, to perform addition, subtraction, multiplication, division, and percentage respectively. In Excel
2016, a formula begins with an equal to (=) sign. You can manually enter the function and formulas. The general
syntax of a function is as follows:

=Function Name (Cell Range)
Example: = SUM (number1, [number2],



('. The Basic Functions and their Syntax ]
Sum The SUM function calculates the sum of values contained in a range of cells.
Syntax: =SUM (number1, [number2],....)
Average The AVERAGE function is used to calculate the average of the values contained in a range of cells.
9 Syntax: =AVERAGE (number1, [number2], ...
C The COUNT function counts the number of cells in a range that contain numbers only.
ount Syntax: =COUNT (Value1, [Value2], ...... )

The MAX and MIN function is used to calculate the maximum and minimum value in the

selected range of cells.
Syntax: =MAX (humber1, [number2], ...)

The LOWER and UPPER function is used to convert the text to lowercase and uppercase
i.e. small letters and capital letters.
Syntax: =LOWER(Text): =UPPER(Text)

Lower and
Upper

he LEN function is used to calculate the number of characters in a text string including spaces.
Syntax =LEN(Text)

The PROPER function capitalizes the first letter of each word of a text string and changes all

Proper other letters to lowercase.
Syntax: =PROPER(Text)

@ AutoSum ]

AutoSum is a built in feature of Excel 2016 that allows you to quickly calculate the sum, count, average, maximum
and minimum of values.

To use AutoSum Feature

- Select the cell where you want to display the result and follow the steps given below
- Select Home Tab or Formulas Tab

- Select the AutoSum Command and follow the steps given below

Home Insert Page Layout Fori

o Click on Sum, to calculate the sum of values. Z ! E !

Financial Logical Text

’ bﬂ Function Library

Count Numbers

v v -

9 Click on Average, to calculate the average of values.

Z Sum

e Click on Count Numbers, to count the number of cells.
Average

o Click on Max, to display the maximum of values.

6 Click on Min, to display the minimum of values. Max

Min
Mooons...




(6' Error Checking J

The Formulas and Functions can sometimes result in error values. The Error Checking command helps you to check
for common errors that occur when using formulas or functions. This command shows you the cells containing the
error, the type of error and other error information. Then you have the access to a number of options to check and
correct these errors.

The table shows some type of errors with their description with examples.

Error/ Solution Description

When a number is divided either by zero (0) or by a cell that contains

REe] @ zero (0) value or no value. (3 @ =As/0

Solution Change the cell reference or value of denominator. =A5/3

#NUM! When a formula or function contains invalid numeric values. \lT;SQRT(-4)

Solution Check and update the formula with valid numbers. =SQRT (4)

#NAME? The Formula is unrecognized i.e. a syntax error. =SSUM(E10:E15)

Solution Use the Function Wizard or type the correct formula. =SUM(E10:E15)
Q"ﬁ’ #VALUE! !:ormula gr oper.ator is' wrong. Also, or'1e or more cells that are =D10, D34

included in an arithmetic formula contain text.
Solution Type the correct operand and make sure the appropriate data is D10+ D34

referenced.

The Niew Tab

The view consists of several groups such as workbook views, show, zoom, and Windows. You will learn about the
freeze panes from windows group.

Book3 - Excel

P

Q Freeze Panes ] 3 split [ View Side by Side =

THide (B Synchronous Scrolling

The Freeze panes used to lock the selected rows and |qc Freeze Switch
columns in place to keep them locked while the rest of the Paness [ Unhide  [Ff Reset Window Position  windows
sheets moving. Freeze Panes

Keep rows and columns visible while the rest of
the worksheet scrolls (based on current selection).
Freeze Top Row

Keep the top row visible while scrolling through 2
the rest of the worksheet.

Freeze First Column

Keep the first column visible while scrolling
through the rest of the worksheet.

You can use this options to freeze just top row, first column
or any selected multiple rows and columns.




WorkbooK Secwu'l:g/

Excel 2016 enables you to secure your work and prevent unauthorized access to your workbook. Workbooks may
contain sensitive information like Credit Card Numbers, National ID Numbers, Employee Information etc. The

following section will guide you through Excel's password protection feature.

- Info
'. Encrypt with Password ] Student

A workbook can be protected with the password
used as encryption to open the workbook. It is

are itive.)
. . By Mark as Fis
recommended to remember the password by listing \ :5:;:31;;:3mm-mm i o o] [ conen
out. Noted forgotten passwords can't be recovered. E— - e
Confirm Password ? x

7] Protect Current Sheet

make to the current sheet.

Ty Restrict Access

ability to edit, copy, or print.
I 1, Add a Digital Signature

dding an invisible digital si

To create a Workbook Password, click on the File Tab and follow the steps given below:

1) In the Backstage view, from the Info option, click on the Protect Workbook command.

2) Click on the Encrypt with Password option from the displayed list.

3) Type the password in the Encrypt Document dialog box and click on the OK button.

4) Re-enter the password in the Confirm Password dialog box.

tect Workbook
| what types of changy
ke to this workbook.

Control what types of changes people c.

[TT] Protect Workbook Structure
Prevent unwanted changes to the struct
of the workbook, such as adding sheets,

@ Grant people access while removing thei

R Ensure the integrity of the workbook by
2

Encrypt Document ?

Encrypt the contents of le
Password:
esscenel
Caution: If you lose or the password, it

cannot be recovered. It is advisable to keep a list of
and their

names in a safe place.
that

Encrypt the contents of t
Beenter password:
eeeesee
Caution: If you lose or 1ol the password, it

cannot be recovered. It is advisable to keep a list of
th

names in a safe,

(Remember t 5 rds are case-sensitive.)

L ok ][ cancel
nature.
]
Bookl.dsx Is protected.
Password:
nt

5) Click on the OK button and save the workbook to apply the password. When you open the workbook, Excel

2016 prompts you to enter the password for the workbook.

)

@ Removing a Password

You can also remove the password from the protected workbook. To Remove the Password, click on the File Tab

and follow the steps given below:

Info

Student

Desktop

1) In the Backstage view, from the Info option
click on the Protect Workbook Command.

Save As

2) Click on the Encrypt with Password option
from the displayed list.

Print

Share

tect Workbook Properties ~
password is required to open Size 26.5K8
is workbook. Title Add a title
Tags Add atag
Categories Add a cate...

[ Markas Final

|_R Let readers know the workbook is final and
make it read-only.

\ _ Encrypt with Password

Related Dates

3) In the Encrypt Document dialog box, B 9| Racuiras s S i
select the password and press the Delete key. et " protectcomentshd ECTYP Document ?
= Control what types of Encrypt the co of this file
. o B make to the current Password: b
4) Click on the OK button and save the Y frosecs ook

of the workbook, sud|
workbook.
Restrict Access
Grant people access
ability to edit, copy,

(e

(s

Add a Digital Signat:
Ensure the integrity of

Caution: If you lose or forget the password, it
cannot be recovered. It is advisable to keep a list o
passwords and their correspond cument
names in a safe place.

(Remember that passwords are

adding an invisible di

gital signature.




List of Acronyms

An expression to perform calculations by using mathematics equation.

A predesigned formula which performs calculations automatically.

A graphical representation of the data

Work area in the excel workbook

Spreadsheets

Ya
The Home Overview of The Page | The Formula
formatting Options wBEERE Layout Tab Tab

Various Spreadsheet The Home Tab Chart and Elements Print Area ,
Prog?rams of a chart — Functions
Print Titles

Inserting chart

Error
Checking

Starting Excel 2016

Design and Format
Tab's-Contextual Tabs
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The View




